Widevine Content Decryption Module Update error – How to fix it?

Do you see a Widewine content decryption module error when visiting Netflix or Amazon Video? Are you tired of seeing ‘component not updated’ every time you try to update WidevineCdm? It’s a common error that many users report when trying to play DRM-protected HTML5 videos.

If you are seeing this error and haven’t been able to fix it yet, this blog post is the last tutorial you will ever need.

Without any further ado, let’s fix this problem. You can enjoy your favorite TV shows and movies on Netflix and other HTML5 websites after this tutorial.

widevine content decryption module chrome

What is Widevine Content Decryption Module?

Widevine Content Decryption module is Google extension for playing digitally protected content using HTML5 player. Google Chrome and new versions of Mozilla Firefox install this extension by default.
When you open your newly installed Chrome or Firefox browser, this extension loads with it.

Google Chrome and other browsers use this plug-in to deliver DRM-protected HTML 5 video / audio content. If you disable or remove this plug-in from your browser, you won’t be able to play videos from many popular websites such as a Netflix and Amazon.

It’s one of the 5 plug-ins that comes pre-installed on your Google Chrome browser. New versions of Firefox also download this module by default. Older versions of Firefox use Adobe Flash for DRM-protected content but don’t support HTML5.

 

Why am I seeing widevine content decryption module update error?

When you visit a website such as Netflix that uses HTML5 videos, you might see an error ‘Widevine content decryption module component not updated’.

You wonder why this error has popped up all of a sudden. It could be due to any of the following reasons.

1- You have disabled this plug-in and now a website requires it

2- The plug-in failed to update itself

3- Somehow, you removed the plug-in

4- A malware or virus might have corrupted the plug-in files

5- The extension has crashed for some reason

When you are seeing this error on certain websites, you can still continue browsing. However, you won’t be able to play DRM-protected audio/video content.

 

Is this error only related to Google Chrome browser?

Although many people report ‘Widevine content decryption module update Chrome’ error, you could see this error in other browsers as well.

 

Widevine content decryption module Firefox

Firefox resisted implementing this plug-in for long. Firefox 51 and below use Adobe Primetime CDM to play DRM-protected content.

Since the release of Firefox 47, Mozilla has also started supporting Google Widevine CDM plug-in.

Just like Chrome, Firefox also downloads Widevine plug-in by default. It runs in a sandbox and the browser will notify you when a website starts this plug-in.

Just like Chrome, you can see the “widevine content decryption module component not updated” error on Firefox.

 

Widevine content decryption module Opera

Opera browser doesn’t support HTML5 video. Since Amazon Prime and other websites streaming DRM-protected videos require HTML5, they won’t play in Opera browser.

However, some DRM-protected videos don’t require HTML5 player. You can easily play these videos in Opera using third-party extensions such as Adobe Flash.

READ  Simple Steps to Fix Windows Error 0x80070422

You can switch to another browser to enjoy DRM-protected HTML5 videos. Google Chrome, Mozilla Firefox, and Microsoft Edge browsers support HTML5.

 

Are there any other plugins to play DRM-protected videos?

Google Widevine is becoming the most popular plug-in to play DRM-protected videos. However, some browsers use other third-party extensions to play digitally protected content.

For example, Microsoft Edge browser uses Microsoft Silverlight to deliver digitally protected content. Similarly, Opera uses Adobe Flash to play such content.

 

Widevine Content Decryption Module Error – The Ultimate Fix for Chrome and Firefox

When seeing Widevine error, it’s easy to fix. Depending on what browser you are using, follow a method below to resolve this error.

 

Fix for Google Chrome browser

In Google Chrome, you could face three major issues with Widevine extension.

1- The extension is not installed

2- You have an outdated version of Widevine and you can’t update it

We will look at each of these cases individually and provide a fix. Depending on what error you are seeing, you can follow the right method to resolve this error.

Follow the steps below to and get rid of error ‘widevine content decryption module update chrome’.

 

1- The extension in not installed

When you visit a website that plays DRM-protected HTML5 content, you might see an error about missing Widevine module.

In case you are seeing this error, follow the easy steps below to fix it.

1- Uninstall Google Chrome from your computer

2- Go to official Google Chrome download page

3- Download and install the browser

4- When the browser installs, it will automatically install Widevine for you

Now visit Netflix or Amazon Prime and play your favorite video. You should be able to have a smooth experience without any errors.

 

2- Widevine is outdated

When you have an outdated Widevine add-on, you will see an error when trying to play DRM-protected content.

To resolve this error, follow the steps below.

1- Type ‘chrome://components’ in Google Chrome and hit Enter

2- Locate Widevine extension

3- Click the Update button under the add-on

4- Your browser should update the plug-in within a few seconds

Unfortunately, for a majority of users, this DOESN’T WORK!

When they click ‘update’, you will see the status as ‘component not updated’. In case that’s happening to you as well, follow the steps below to resolve this error permanently.

Uninstall Google Chrome and perform a fresh installation

This step is self-explanatory. You simply need to uninstall Chrome from your computer. Then download from the official page and install the browser.

In most cases, this should resolve “Widevine Content Decryption module update” error. As a result, you can enjoy DRM-protected HTML5 videos again.

In this didn’t solve your problem and you are still seeing the error, move to the next step below.

Disable your antivirus and firewall

Sometimes, you are unable to update this add-on because your security software is preventing Widevine from updating itself.

READ  Easy Approach to Fix a Windows 10 Upgrade Stuck at 99%

Disable your security software and update the add-on again as you did earlier. The plug-in should update within a few seconds.

However, if you are still seeing ‘status: component not updated’, then move to the next step below.

Check user control and fix it

If your login user doesn’t have full control to edit the extensions folder, you will see this error despite following the above steps.

When your login user doesn’t have full control, it can’t make any changes to extensions folder. In that case, the browser will not be able to update the extensions as well.

Follow the steps below to resolve this problem.

1- Press Windows key and R key together

2- Run box will pop up

3- Type the following command without quotes and hit Enter
“%userprofile%appdata%local”

4- A pop-up window will appear

5- Click on Google, then Chrome, and then User Data

6- You should be able to see WidevineCdm listed on the User Data tab

7- Click on Properties and go to Security panel

8- Click Edit

9- Make sure “Deny catalog’ is unchecked

10- Click Apply

Now your user has the control to edit WidevineCdm folder. Update the extension now by going to ‘chrome://components’.

It should work now. You should be able to enjoy your favorite HTML5 DRM-protected videos from Amazon Prime, Netflix, and other websites using Widevine.

 

Fix for Mozilla Firefox browser

Follow the steps below to resolve this error for Firefox browser.

1- Click on the menu button in Firefox browser

2- Choose Add-ons from the options

3- Select Plugins when the Add-ons manager pops up

4- Locate ‘Widevine Content Decryption Module provided by Google Inc.’ in the list of installed add-ons

5- Select the option “Always Activate” on the menu next to the Widevine extension

6- Restart your browser

Sometimes when the add-on has been removed from your browser, it won’t show up in Add-ons manager. In that case, follow the steps below to install this add-on.

1- Click on the menu button in your browser and go to Options

2- Open General panel when the Options window pops up

3- Select “Play DRM-controlled content’ under ‘Digital Rights Management (DRM) Content’ option

4- Now your browser will download Google Widevine Content Decryption Module Firefox

That’s it. You should be able to play HTML5 DRM-protected videos from Amazon Prime and Netflix without any error on Firefox.

 

This tutorial should help you to play HTML5 videos in your browser even when they are DRM-protected. You should be able to update Widevine Content Decryption Module easily, whether using Chrome or Firefox. That means you can enjoy tons of premium content from Netflix and Amazon at the best quality. Go ahead and grab a bag of pop corn as the fun time is about to begin.

Leave a Reply